Cumulus doesn't update external sites

New setup, Cumulus is not updating external sites.

Problem: Neither WeatherUnderground nor Vintners.NET PMI are getting data.
In summary, there are two firewalls between you and the Vintners.net PMI server, and one or both are probably what's preventing this from working.
  • Download and install "FileZilla" program and see that it behaves the same. This problem usually manifests itself as a timeout, then retry in FileZilla. Use the Vintners.net PMI acct info for this (Same info as Client Install section L).

  • Confirm your settings in Cumulus->Configuration-Internet Settings.
    In the "Web Site" block, check the ftp server "Host name" should be "ftp.vintners.net", "FTP port" should be "21". (See Client Install section L)

  • While we're here, confirm your settings for WU. In the "Weather Underground" block, make sure "Enabled" and "Catch Up" are both checked. (See Client Install section K).
    Check that "Station ID" is the KWA.....### ID that you were given by WU.
    Check that the "Password" is the "station key" you were given by WU.

  • In Cumulus hit the "Configuration" tab, and select "FTP Logging". If it already has a checkmark next to it, simply leave it, we want this logging to be on.

  • In Cumulus, hit the "File" tab, and select "Web Update". You should immediately get a small popup window that says something like "connecting".

  • Assuming the previous popup just hangs there, it's probably the "Windows Defender Firewall" preventing access. Do a google search for "win10 disable firewall" (or whichever version of windows you're using) and turn it off. Now go try the Web Update again. Whether it works or not, after a few mins, turn the firewall back on. Here's a link to the Microsoft page on how to en/dis-able firewall

  • If that did make it work, we'll need to enable FTP through the Windows Defender firewall. Google this, and do it. Go into Windows Control panel, enter "firewall" into the search bar. Click on "Advanced Settings" in the left bar. Under Inbound Rules, look for "File Transfer Program". There should be two of them (UDP and TCP), make sure each is enabled and set for "allow". Find "FileZilla FTP Client", again there will be two. Make sure they are both enabled and set for "allow". Find "Cumulus". Make sure it is enabled and allowed. Note that I don't believe there needs to be a corresponding outbound rule.

  • If the above did not fix it, it may be your modem firewall. Google for help with your make/model. I have CenturyLink DSL with a Zyxel C3000Z modem, here's how I had to do it.
    In your web browser, go to address http://192.168.0.1. You should get an admin login screen. The admin acct and pswd are on a sticker on the bottom of your modem.
    Once in, click "Advanced Setup", icon on top right. Next click "IPv4 Firewall".
    Click here for sample modem firewall settings screen. Red oval in left bar is where you click to get to this screen. Make sure the green oval at top center is set to "All Public IP Addresses". Check that in the list below, "FTP" and "FTPS" are configured as shown. FTP, "File Trasfer", 20-21 TCP, allow in and out. FTPS, "Secure File Transfer", 990 TCP, allow in and out.

  • Note: If you're having Cumulus provide data to "CWOP", you will have to add a special rule for that. Name it "Cumulus/CWOP", TCP, port 14580, allow in and out.
Copyright © 2012-2022 Mike Lempriere         Website hosting by Vintners.Net (running on host: pedicel)