Cumulus console display problems

This is for the Cumulus website "Console" displayed at the PerennialVintners/Vintners.net website in your browser.

Sample console screen

The URL to your weather station console will be:
http://www.PerennialVintners.com/weatherstation/[your system name]/

Your system name was determined by the second step in the client_install directions. List of stations here.

The URL for PMI program access is: http://www.PerennialVintners.com/weatherstation/pmi.php


At top left, in blueish-gray blocky lower-case letters, says simply "weather"; should say "[location] weather".
In sample screen, the purple highlighted area is missing.

This is the "#location" tag string from Cumulus. You have not filled in a location in the Cumulus->Configuration->Station screen, "Name" field (right smack in the middle of the config. screen) screen shot.


Near top left, in normal text, "Latitude", etc. blank.
In sample screen, the orange highlighted area.

These are the "#latitude", "#longitude", and "#altitude" tag strings from Cumulus. You have not filled these in in the Cumulus->Configuration->Station screen screen shot.


Near top left, in normal text, says "Welcome to"; should say "Welcome to [name]".
In sample screen, the gray highlighted area is short.

This is the "#longlocation" tag string from Cumulus. You have not filled in a name in the Cumulus->Configuration->Station screen, "Description". screen shot


Top of almanac table, in normal text, says "Conditions at local time"; time is way off.
In sample screen, the light-blue highlighted area.

This is the "#time" tag string from Cumulus and is filled in automatically when this web file is uploaded to the server. If this time is close to the current time, all is working -- the server uploads this file every few minutes (The default is 10 mins). If you wish to change the upload frequency, this is the "Web Settings" "Interval" field in the Cumulus->Configuration->Station screen, config screen shot (see pink highlight).

You can force an immediate update by Cumulus->File->Web Update screen shot.

If that's not it, this time value is derived from the system clock of the PC running Cumulus. Check that the time is set correctly on that machine. Directions in the New Client Install page.

If the forced "Web Update" does update and, yet things don't keep updating, check that the "Auto Update" setting is checked on the Internet Settings->Sites/Options tab. See "#time" paragraph above.


At top left of screen, to left of the blueish-gray blocky lower-case letters saying "[location] weather", there's no image.
In sample screen, the green highlighted area is missing.

This image is called out in the "weatherstyle.css" file. As delivered, it displays "images/picture.jpg". This should not be much more than about 128x128px.

If you followed the client_install instructions and ftp'ed this up from the Cumulus directory, their default image is a seagull in flight.

This is where you would put your vineyard/winery logo. You should put a copy of it in your Cumulus "webfiles/images" directory in case it's ever needed again, but it only needs to be present on the webserver to function. See client_install instructions for ftp uploading this file to server.

I have seen cases where this image only shows up in the iPhone Safari browser, it's not visible in IE, Edge, Chrome, Opera or FireFox -- very weird. If it's not working for you, the above is all I know. If you dig in to the .css file or some such, and find the fix, be sure to let me know.


Text only, with moon phase image. No color bars, no color background.

You're missing the weatherstyle.css file from your html/weatherstation/ directory. Mike should have put that there for you. You can upload it from your \Cumulus\webfiles\ directory, or ask MikeL to put it there for you.

Copyright © 2012-2020 Mike Lempriere         Website hosting by Vintners.Net (running on host: pedicel)